-
Posts
645 -
Joined
-
Last visited
-
Days Won
101
Content Type
Profiles
Forums
Downloads
Tutorials
Everything posted by Morpheus
-
I'm not sure, but its a warning and can be ignored.
- 4 replies
-
- snort
- postgresql
-
(and 2 more)
Tagged with:
-
Try reversing the slashes: Change from: \i d:\winids\barnyard2\schemas\create_postgresql; Change to: \i d:/winids/barnyard2/schemas/create_postgresql; Let me know if that works... Can you also try removing the ; at the end to see if it works?
- 4 replies
-
- snort
- postgresql
-
(and 2 more)
Tagged with:
-
'uname' error
Morpheus replied to belnando's topic in Issues with Rules in the Windows Intrusion Detection system
You need to configure line number: 190 snort_version=x.x.x.x -
'uname' error
Morpheus replied to belnando's topic in Issues with Rules in the Windows Intrusion Detection system
Attach your pulledpork.conf file. -
'uname' error
Morpheus replied to belnando's topic in Issues with Rules in the Windows Intrusion Detection system
You need to post a screen shot of the complete error. Did you run the modder.vbs file? Did you install the version of Strawberry perl per the tutorial? Did you install to the d:\ drive? -
'uname' error
Morpheus replied to belnando's topic in Issues with Rules in the Windows Intrusion Detection system
It's not an error, its a warning because it's not supported in Windows. Too bad because it would make updating the rules so much easier. There may be a way to do this with a Windows equivalent, or possibly Cygwin, but I've not looked directly into that. There will be a bunch of warnings showing up, they are purely informational, and never a show stopper. -
Blank Security Console
Morpheus replied to belnando's topic in Discussing Manual Installation for IIS with MySQL Logging
Where exactly in the tutorial is it failing? -
It's been here for a very long time and just works for basic purposes. I think Windows will now actually allow email notifications as part of its core functions for triggered events. You might try looking at this I'm sure there are a few way to go this. Search for sending email alerts on windows events. The above should do the trick, or possibly something similar. Let me know if this helps and it could be a good alternative to the existing way its documented.
-
I'm not real sure about these items as I haven't used PP in a very long time. I usually pull it up when something goes wrong to fix. 1) You are saying that running the test for Snort 'd:\winids\snort\bin\snort -c d:\winids\snort\etc\snort.conf -l d:\winids\snort\log -i1 -T' produces this error: I ran the test (d:\winids\snort\bin\snort -c d:\winids\snort\etc\snort.conf -l d:\winids\snort\log -i1 -T) and am not seeing this error? You said there is something missing in the 'C:\Windows\System32\drivers\etc\protocol' file: Here is the file: # Copyright (c) 1993-2006 Microsoft Corp. # # This file contains the Internet protocols as defined by various # RFCs. See http://www.iana.org/assignments/protocol-numbers # # Format: # # <protocol name> <assigned number> [aliases...] [#<comment>] ip 0 IP # Internet protocol icmp 1 ICMP # Internet control message protocol ggp 3 GGP # Gateway-gateway protocol tcp 6 TCP # Transmission control protocol egp 8 EGP # Exterior gateway protocol pup 12 PUP # PARC universal packet protocol udp 17 UDP # User datagram protocol hmp 20 HMP # Host monitoring protocol xns-idp 22 XNS-IDP # Xerox NS IDP rdp 27 RDP # "reliable datagram" protocol ipv6 41 IPv6 # Internet protocol IPv6 ipv6-route 43 IPv6-Route # Routing header for IPv6 ipv6-frag 44 IPv6-Frag # Fragment header for IPv6 esp 50 ESP # Encapsulating security payload ah 51 AH # Authentication header ipv6-icmp 58 IPv6-ICMP # ICMP for IPv6 ipv6-nonxt 59 IPv6-NoNxt # No next header for IPv6 ipv6-opts 60 IPv6-Opts # Destination options for IPv6 rvd 66 RVD # MIT remote virtual disk What exactly needs to be added? igmp 2 IGMP # Internet Group Management Protocol It this something that should be included? I can automatically search the 'C:\Windows\System32\drivers\etc\protocol' file when the modder.vbs runs, and add the setting if it's missing. As a note: PP is extremely powerful rule management tool, and it's been my experience that asking question in the snort-users group will get answers faster than in the pullerpork-users group.
-
Open a CMD window and type: reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion" /v CurrentVersion Note: you should get something like the below. In this case the "CurrewntVersion" number is 6.9. You should be seeing something different "CurrentVersion" because of the warning message received. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion CurrentVersion REG_SZ 6.9 Open the 'modder.vbs' file with a text editor. Go to line 16 and add the new "CurrentVersion" number, and save the file. Example below is based on the "CurrentVersion" of 6.9 above: Case 6.0, 6.1, 6.2, 6.3, 6.9:
-
Bad CGI?
Morpheus replied to NateObee's topic in Discussing Manual Installation for IIS with MySQL Logging
This below is documented in the tutorial. Have you moved the test.php to the d:winidsinetpubwwwrootbase folder and see if you can access that file through the browser? You should zip up the C:WindowsSystem32inetsrv folder, and attach that along with your php.ini file. -
snort.exe fails to start
Morpheus replied to KiRyah's topic in Issues with Rules in the Windows Intrusion Detection system
Test the snort installation... Go back to the section labeled Testing the Snort configuration and rules and complete. Post the output if it fails. Configuration files should be attached, and not posted in a reply. -
Remote access is as simple as having the appropriate port opened on the master database to the outside world, and giving the remote client the appropriate permissions to connect to the master database. Keep in mind that this is NOT secure way to connect client to master, and Winsnort.com has not tackled that in a tutorial, as it is an advanced option. My guess is; if you have made sure that the default port of 3306 is open to the outside world on the master sensor, and it has been verified, then its most likely a user permission problem. You might want to setup a specific user account for remote access and adjust the barnyard2.conf for access.
