Sign in to follow this  
Followers 0
hcol1987

Barnyard2 service doesn't start after successful installation

2 posts in this topic

I followed the guide posted on this forum, but Barnyard2 service doesn't start after computer restart. If I try to start it manually from Windows Services, then Barnyard2 crashes. I did not get any errors while installing Barnyard2. This is output from the command "c:winidsactivatorsby2-test" (I have replaced all paths where drive d is referenced, because I use c drive):

 

C:Windowssystem32>c:winidsbarnyard2barnyard2.exe -c c:winidsbarnyard2etc
barnyard2.conf -d c:winidssnortlog -f merged.log -l c:winidsbarnyard2 -w c
:winidssnortlogbarnyard.waldo -T
Running in Test mode
 
        --== Initializing Barnyard2 ==--
Initializing Input Plugins!
Initializing Output Plugins!
Parsing config file "c:winidsbarnyard2etcbarnyard2.conf"
 
 
+[ Signature Suppress list ]+
----------------------------
+[No entry in Signature Suppress List]+
----------------------------
+[ Signature Suppress list ]+
 
WARNING: invalid Reference spec 'url,'. Ignored
WARNING: invalid Reference spec 'url,'. Ignored
Barnyard2 spooler: Event cache size set to [32768]
INFO database: Defaulting Reconnect/Transaction Error limit to 10
INFO database: Defaulting Reconnect sleep time to 5 second
database: compiled support for (postgresql)
database: configured to use mysql
database: schema version = 107
database:           host = 10.165.17.82
database:           port = 3306
database:           user = snort
database:  database name = snort
database:    sensor name = SNMP-agent3-win
database:      sensor id = 3
database:     sensor cid = 1
database:  data encoding = hex
database:   detail level = full
database:     ignore_bpf = no
database: using the "log" facility
 
        --== Initialization Complete ==--
 
  ______   -*> Barnyard2 <*-
 / ,,_    Version 2.1.13 (Build 333)
 |o"  )~|  By Ian Firns (SecurixLive): http://www.securixlive.com/
 + '''' +  © Copyright 2008-2013 Ian Firns <firnsy@securixlive.com>
 
 
Barnyard2 successfully loaded configuration file!
Barnyard2 exiting
database: Closing connection to database "snort"
EDIT: I have found what the problem was. The VB script tried to open Barnyard2 from drive D.

Share this post


Link to post
Share on other sites

So it appears it is working correcty. Did you run the .reg file, and did you modify it to reflect the path changes before running it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0